Symptoms
When using HubSpot triggers or actions in your Zaps, you see the error message “You have reached your secondly limit”
. You’ll see this error in the details of a Zap run in your Zap's history.
Causes
This happens when your Zap runs frequently in a short amount of time, causing you to exceed HubSpot’s rate limit. These API limits are set account-wide.
How to fix
To fix this:
- Reach out to HubSpot to increase your API usage.
- Review Hubspot’s API usage guidelines.
- If you cannot increase your API usage, review the number of Zaps you’ve connected to HubSpot. Disabling Zaps can help reduce the number of unnecessary requests to HubSpot.
For HubSpot actions
Besides increasing your API usage:
- Add a Delay After Queue action before your HubSpot action. This will queue your actions and play them one-by-one in the order they were added.
- When setting up your Delay step, set the delay time to 1 minute or more.
Still need help?
If this article did not fix the issue, Zapier has a few other options to get you the help you need:
- Contact Zapier Support. Our Support team can investigate your account to find solutions.
- Ask in the Zapier Community. Get advice from experienced Zapier users in the Zapier Community.
- Learn more about getting help. Read our guide on how to get help and support with Zapier to find the best resources for your specific problem.
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