When using a HubSpot update action in your Zaps, you get the error message "Object not found. objectId are usually numeric." You’ll see this error in the details of a Zap run in your Zap's history.
Causes
This happens when the value in the Object ID field contains text, such as an email address or the name of a deal. This field in HubSpot accepts numerical values only.
How to fix it
To fix it:
- Add a HubSpot find action before your update action. This action will find the object's corresponding numerical ID value in Hubspot.
- For example, add a Find Deal action before your Update Deal action.
- In your HubSpot update action, in the Object ID field, map the numerical ID field from the previous step.
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