In the Zap editor or Zap history, you see an error message related to SSL operations, typically shown as:
- "SSLError The read operation timed out"
- "ExternalHTTPSConnectionPool(host='sheets.googleapis.com', port=443): The read operation timed out."
Causes
This error arises due to the limitations of Google Spreadsheets in handling large datasets. Spreadsheets with over 100,000 rows can pose challenges for Zapier to access and process the data effectively.
How to fix it
To fix this problem, follow these steps:
- Reduce spreadsheet size. Consider creating a new spreadsheet with only the necessary data or remove unused columns. If you need to move or delete rows, disable the Zap before making the changes and re-enable it afterwards.
- Replay the task. If the error appears with Google Sheets as the action, indicating data loss, try replaying the specific task from your Zap history to recover the lost data.
- Consider changing your app. For larger datasets, consider other apps, such as Airtable or MySQL, better suited for handling large databases. Learn more about the database apps Zapier supports.
Still need help?
If this article did not fix the issue, Zapier has a few other options to get you the help you need:
- Contact Zapier Support. Our Support team can investigate your account to find solutions.
- Ask in the Zapier Community. Get advice from experienced Zapier users in the Zapier Community.
- Learn more about getting help. Read our guide on how to get help and support with Zapier to find the best resources for your specific problem.
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