When you use a create or update action in Google Sheets, you see an error message of "the app returned” “the caller does not have permission". This happens when testing the Zap or if the Zap is live.
Causes
This happens if you do not have sufficient permissions to edit a spreadsheet.
How to fix it
To fix this:
- Open the Google Sheet spreadsheet you want, using the same account that is connected to the Zap.
- In the top right, click Share.
- Check you have Editor permission. If you lack Editor permissions, ask the spreadsheet owner to give you Editor access.
Still need help?
If this article did not fix the issue, Zapier has a few other options to get you the help you need:
- Contact Zapier Support. Our Support team can investigate your account to find solutions.
- Ask in the Zapier Community. Get advice from experienced Zapier users in the Zapier Community.
- Learn more about getting help. Read our guide on how to get help and support with Zapier to find the best resources for your specific problem.
0 comments
Article is closed for comments.