When using any Google Sheet search action, you see the error message "Nothing could be found for the search."
This error will appear in the Zap editor when testing Zap steps or in Zap history after your Zap runs. The Zap run status will display as stopped.
Causes
This happens when:
- The mapped field from the previous step in the Lookup Value or Title field is blank and is required for the search to be completed.
- The value in the Lookup Value or Title field does not match what’s in Google Sheets.
How to fix it
To fix the issue:
- Ensure the data from the previous step is consistently sent to the Google Sheets step, or replace the current mapped field with one that consistently provides a value.
- If you cannot change the current mapped field, you can either:
- Add a step to set a default value as a fallback whenever your mapped field does not have any data.
- Add conditional logic using a filter or branching logic with paths to your Zap. This will allow you to define what the Zap should do if the Lookup Value or Title field receives no data from the previous step.
- Ensure the data coming from the previous step matches the format your spreadsheet expects.
- If the data is in a different format than what is in the spreadsheet, add a Formatter step to convert it to the correct format.
- Learn more about using Formatter.
Still need help?
If this article did not fix the issue, Zapier has a few other options to get you the help you need:
- Contact Zapier Support. Our Support team can investigate your account to find solutions.
- Ask in the Zapier Community. Get advice from experienced Zapier users in the Zapier Community.
- Learn more about getting help. Read our guide on how to get help and support with Zapier to find the best resources for your specific problem.
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