When using any Gmail’s actions in your Zaps to send an email with an attachment, you see the error message "Unauthorized". You may see this error when setting up a Zap or in the details of a Zap run in your Zap history.
Causes
This happens when your file URL in the Attachment field is not downloadable or publicly accessible.
How to fix it
To fix this issue:
- Test if a file’s URL is accessible or downloadable:
- Open an incognito browser and copy and paste the URL into the address bar.
- Press Enter on your keyboard.
- One of the following will happen:
- The file will display in the browser window if it’s a viewable format.
- The browser will download the file to your computer.
- If the file cannot be accessed, you may see an error message. This means Zapier cannot access the file. Learn more about sending files in Zaps.
- Adjust the permission settings on your file to public.
- If you cannot adjust the permission settings on your file, you will need to add the file to a File Management or Storage app where you can adjust the permissions.
Still need help?
If this article did not fix the issue, Zapier has a few other options to get you the help you need:
- Contact Zapier Support. Our Support team can investigate your account to find solutions.
- Ask in the Zapier Community. Get advice from experienced Zapier users in the Zapier Community.
- Learn more about getting help. Read our guide on how to get help and support with Zapier to find the best resources for your specific problem.
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