When using the Send Email action, Zapier might display an error message: “Email by Zapier: Sorry! That is too many emails sent. Please try Mandrill, Mailgun, Gmail, or others for bulk email”. This usually occurs when the Zap is turned on.
Causes
This happens when the Email by Zapier app reaches the limits the number of emails an account can send within a specific timeframe to prevent spam. This limit applies to your entire Zapier account, regardless of how many users are on it.
The limit is:
- Trial or Free plan: 5 emails per account per hour.
- Any paid plan: 10 emails per account per hour.
For multi-user plans, such as Team or Enterprise, this means if one user sends 10 emails in an hour, the entire account reaches the limit, and no one else can send emails by Email by Zapier until the hour passes.
How to fix it
To fix the issue, follow these steps:
-
Review your trigger settings:
- Check if you can adjust the frequency of your trigger. Some triggers may allow you to refine when your trigger should run.
- Use an alternative trigger in your Zap.
- Upgrade to a paid Zaps plan: This will increase your limit to 10 emails per hour. This is a good option if you regularly need to send more than 5 emails per hour. Learn more about changing your Zaps plan.
- Use an alternative email app: If you need to send more than 10 emails per hour, consider using a different email app, such as Mailchimp Transactional, Mailgun, or Gmail. These apps typically offer higher sending limits and may be better suited for bulk-sending emails.
0 comments
Article is closed for comments.