When using Pipedrive’s Create Lead action, you get the error “Neither an Organization nor a Person were provided”. You may see this error when setting up a Zap or in the details of a Zap run in your Zap history.
Causes
This happens when the Person and Organization fields are mapped with fields containing text instead of IDs.
How to fix it
To fix it:
- If necessary, add Find Person and Find Organization action steps before the Create Lead action. This step is only necessary if the preceding steps only provide a person's or organization's name instead of the person ID and organization ID.
- In your Create Lead step:
- Remove the currently mapped fields for Person and Organization.
- Replace them with fields containing the person ID and the organization ID.
Still need help?
If this article did not fix the issue, Zapier has a few other options to get you the help you need:
- Contact Zapier Support. Our Support team can investigate your account to find solutions.
- Ask in the Zapier Community. Get advice from experienced Zapier users in the Zapier Community.
- Learn more about getting help. Read our guide on how to get help and support with Zapier to find the best resources for your specific problem.
0 comments
Article is closed for comments.